Wikia

RuneScape Wiki

Talk:The Curse of Arrav

25,745pages
on this wiki

Back to page | Redirected from Talk:The Curse Of Arrav

This talk page is for discussing The Curse of Arrav.

Rewards Edit

Anyone know what the rewards are?

No, but the rewards listed currently are completely false, they make no sense. The only thing currently known is that only 1 quest point is rewarded.


Come on guys, stop mucking the page up! Until the rewards can be proven, don't make a guess edit! Couchodyj95 16:20, 21 July 2009 (UTC)

The rewards listed now are the correct ones, I've completed the quest about an hour and a half ago. ArnoudX 16:42, 21 July 2009 (UTC)

Yea, and I'm checking every once in a while to remove the vandalism, --kazypoo1 16:24, 21 July 2009 (UTC)


Asking Ali for what?! That is false, who would put that? --User:WingedMouse

Djpailo‏, stop your constant vandalism, you are really spoiling the hard work people are putting in to this page! Couchodyj95 16:27, 21 July 2009 (UTC)

Djpailo doesn't seem to have made any bad edits to this page, glancing through his contribs. JalYt-Xil-Vimescarrot 16:31, 21 July 2009 (UTC)
As far as I could gather, the updates I was getting regarding this vandalism were editted by Djpailo‏. These were the constant youtube links being shown and replacing the walkthrough and the 'talk to Ali, ask for sex.' Sorry if I am mistaken. Couchodyj95 16:37, 21 July 2009 (UTC)

If you go on Runescape website > Manuals > quests > The Curse of Arrav the spoilers say that the quest reward is "Like Arrav, the rewards are cursed! Please check back tomorrow - we have our best exorcists, soothsayers and alchemists working on the problem. " which probably means that the rewards are glitched.

It means that the rewards aren't going to be shown by Jagex to give it a suprise for the eager questers who complete it first. They will be shown tomorrow, probably.

Look i removed that ali for sex thing, and when it became semi protected i was happy, at least i dont have to worry about it now, --kazypoo1 16:34, 21 July 2009 (UTC)

I'm very new to this scene but here's a screenshot of the rewards hosted by imageshack, sorry it's not cropped or uploaded here, something was wrong with it when i tried. :(

zcreenshot107.png

JaydenB 16:37, 21 July 2009 (UTC)

Thanks Jay. I couldn't bother making a Screenshot... ArnoudX 16:45, 21 July 2009 (UTC)

Sorry, yeah I got the information on the rewards from Zybez. Obviously we can't us their screenshot though.

I didn't add those youtube links either??

I've also been editing the main page with basic quest info, nothing too well written out, just to give an outline on what to work with, sorry. :) JaydenB 17:06, 21 July 2009 (UTC)

boosts? Edit

does anyone know if you can boost for quest reqs?

Read the guide, it says you can use boosts for quest reqs.

Climbing Boots Edit

They are NOT needed for this quest. 173.79.93.183 16:59, 21 July 2009 (UTC)

Jaden, why did you accuse me of putting youtube links on the page and then vandalise my own page? --Djpailo 17:21, 21 July 2009 (UTC)

The climbing boots are needed for the quest, only if you don't use a Trollheim Teleport though - so that's something they should mention in the item requirements :)Vespire 17:50, 21 July 2009 (UTC)


I moved and edited the climbing boots and trollhiem teleport so they are together, but maybe, since you must use one of these options, they should be moved to required item, instead of recommended items? Rand14 19:15, 21 July 2009 (UTC)

Typo! Edit

Just thought I'd bring it to all of your attention so you can put it in the trivia section, there's a typo on the Notes (A-Z) item in the text "He still outlives those outdated Zaorsian ideals" (Zarosian has been mispelt) ^^

New member btw :P

Vespire 17:37, 21 July 2009 (UTC)

About the Sequel Mentioned... Edit

Paul didn't directly say there was a sequel, he said that there was more to come. I think the part about the sequel should be replaced with that, and that it could mean that there could be a sequel, but whether it's in the Mahjarrat or the Avarroka quest series (i hope i spelled that right) or both is unknown

Of course there is going to be a sequel. The quest ended too abruptly to not get a sequel.-- Ruderion (Talk) Farming cape (t) 20:13, 21 July 2009 (UTC)


Quest Series Edit

I think that the quest series should be changed be cause when reading the news article Paul clearly states that this quest is part of the defender of varrock series while this says it is part of the tale of muspah series.

Its both. 80.222.213.219 20:51, 21 July 2009 (UTC)

From Runescape itself:

"This quest is a continuation of the Mysteries of the Mahjarrat quest series. It’s also a sequel to a previous quest I wrote - Defender of Varrock.
Paul
RuneScape Content Developer"

So it should lie in the Mahjarrat quest series. Rand14 01:05, 22 July 2009 (UTC)

Factual correction Edit

It needs to be made clear that you need to go to the terminal in order to figure out the code to open the door. Many people are having trouble figuring this out. Thanks.

I edited/added some information for that section. Hope that helps. Lil cloud 9 22:24, 21 July 2009 (UTC)

Added a new reward picture in proper quality.

This page should be moved! Edit

This page should be moved to the page with the title "The Curse of Arrav" the 'O' should not be capitalized, as show in-game. —The preceding unsigned comment was added by Camoninja12 (talk).

It was capitalized in the knowledge base. Santa hat Powers38 おはようヾ(´・ω・`) 00:58, 22 July 2009 (UTC)

If you look that the screen shot of the rewards above, or look at the In-game listing of the quest you will see that the 'O' is lowercase. —The preceding unsigned comment was added by Camoninja12 (talk).

Additional Research Edit

I think this should be moves to after the Reward Section, since it is not done during the quest. Rand14 01:00, 22 July 2009 (UTC)

I think it would be nice. I just read it and before the final paragraph it said "......talk to Ali the wise to finish the quest." You can move it to the Reward section if you like. Santa hat Powers38 おはようヾ(´・ω・`) 01:04, 22 July 2009 (UTC)


Nightgunner1, Please discuss your reasons for deleting other peoples work, without discussing on these pages first. Rand14 04:52, 27 July 2009 (UTC)

Anyway, I noticed that Fight Arena was not one of the quests that you could discuss the results of with Ali the Wise (and yet the main antagonist is majaharrat Khazard). Can anyone confirm that Khazard is one of the majaharrat you can talk to Ali about? Wrathanet 02:08, 14 August 2009 (UTC)

"You now have all the levels..." Edit

Ok, I just got 64 Ranged, and the skill guide says "you now have all the levels needed to complete The Curse Of Arrav!", however, I need 66 Thieving along with 64 Mining, still. How can this be? I read on Zybez that all but Summoning are boostable skills, so why am I getting this message if I could boost Ranged in the first place? -- Quest point cape Lil Diriz 77 Talk Summoning-icon 03:41, 22 July 2009 (UTC)

Hey um, yeah i got that as well for summoning 41. I've taken a print screen of mine, does anyone want me to upload it? -Xp5 Chaos-

That happened with me when I got 61 Agility, it said that too. I still need 66 Thieivng and 64 Mining.

Tempoary Boosts Edit

I vote for adding information on when do they work. I haven't started the quest myself, but it looks like the strength, agility and ranged are for doing some grappling, so I'd like to know if I can boostthrough this part, or even start without having the requirements.

Like all quests, you must have completed the quests which are a requirement. The first skill you need is Mining, for getting through the pieces of rubble in the tunnel. Hope this helps. Miasmic blitz Hapi007 Talk! Sign! . 13:29, 23 July 2009 (UTC)

This page should be moved! (2) Edit

Alright for the second time! - This page should be moved to the page with the title "The Curse of Arrav" the 'O' should not be capitalized. Look at the recently added articles section on the front page of both (RuneScape) and (RuneScape Wiki), lowercase 'O'. And if that fails, look on the forums for the actual news post by Paul the 'O' is lowercase. I moved this page once this morning, and now it's been moved back...I will move it again later if this in not fixed. I honestly could care less if I get kicked of the Wiki for this reason. Why give misinformation to your viewers? Look at other quest example "The Legacy of Seergaze." the 'O' is lowercase! —The preceding unsigned comment was added by Camoninja12 (talk).

I see that I'm still being ignored, note - I did NOT create the page "The Curse of Arrav" I simply want the page moved to the title to be correct. The Admin's have told me to look in the quest list in game, which I have, yes it is capitalized in there! I have supplied 4 examples of where it is lowercase, and the way it should be, but the Admin's of this site could care less what an normal user such as myself thinks. I'll list the examples of where it is lowercase.

1.) The Main page of RuneScape. 2.) The Knowledge Base page for the quest. 3.) The news post by Paul in the Recent Updates forum on the RuneScape website. 4.) Numerous screen shots of the Rewards scroll from the quest showing the 'o' as Lowercase. —The preceding unsigned comment was added by Camoninja12 (talk).

I'm the admin who deleted the page Camoninja12 created ("The Curse Of Arrav"). No one is ignoring you, Camoninja. I'm not being elitist or ignoring you in any way. And it is not true that the administrators here couldn't care less about what you think (see RS:AEAE). I wasn't even aware of the fact that you had previously posted on the page. In any case, the Main page/KB have been known to provide names different from the quest name in-game, but so far, we've always stuck with using the name provided in the quest list in-game. Thus, we are using the quest name provided in-game (in this case, "The Curse Of Arrav"). C.ChiamTalk 14:32, 22 July 2009 (UTC)

Identical Notes ~ Thief Requirement Redundancy! Edit

I have a questaccount, MM level 15, with whom I check bugs(for reporting)/redo quests/etc. . I only have Thieving 64, and I forgot to take my Thieving Booster with me. I discovered it, and heck, felt annoyed. However, due to my stubborn attitude, I decided to try a theory.

I asked my friend for his code, which turned out to be IIAC. I used my strips for IIAC, and it WORKED. I actually made the thieving requirement for myself redundant, thus anyone without the thieving requirement could do it! This may be considered a bug, but I think that it shouldn't be called so. My Main Account, Arnoud X122, had the code BHCE. I also heard about a friend of mine, who had the exact same code. There might be up to around 20 codes, I guess. Should it be worth noting them for those without the thieving level, even while you have 2 tries before getting stunned? It would limit them to 10 stuns, and thus make the thieving requirement completely redundant! ArnoudX 13:32, 23 July 2009 (UTC)


This is really interesting, and I think it should be tested - buy I disapprove of your use of the word 'redundant'. Crimson_charm.gif Its Alex Pan 23:50, January 20, 2010 (UTC)

Identical Notes Project Edit

Please tell us what your Code for opening the door to Zemouregal's Vault was. Multiple posts with the same code are needed for verification, to avoid accidental mistakes, and to avoid liars(Sorry, this is only for those who feel like ruining the Wikia's Truth Value):

Confirmed codes:
AFIG
BBAG
BEID
BFGC
BGFI
BHCE
CCCI
CHCI
DEEI
FGHG
FIIG
GABA
HEBF
IIAC
Confirmed Codes: 14
Codes Needing Confirmation:
AABG (Needs Confirmation)
AAIH (Needs Confirmation)
AIEC (Needs Confirmation)
AFAH (Needs Confirmation)
BAIE (Needs Confirmation)
BDDB (Needs Confirmation)
BDGI (Needs Confirmation)
BEFA (Needs Confirmation)
BEGG (Needs Confirmation)
BFEB (Needs Confirmation)
BGBB (Needs Confirmation)
CABE (Needs Confirmation)
CBEH (Needs Confirmation)
CCHH (Needs Confirmation)
CFBG (Needs Confirmation)
CGIH (Needs Confirmation)
DHHH (Needs Confirmation)
EADC (Needs Confirmation)
EFAE (Needs Confirmation)
FEAF (Needs Confirmation)
FHGE (Needs Confirmation)
FHBH (Needs Confirmation)
GAFG (Needs Confirmation)
GCCB (Needs Confirmation)
GDFI (Needs Confirmation)
GEFC (Needs Confirmation)
GIGD (Needs Confirmation)
HEEB (Needs Confirmation)
HFIF (Needs Confirmation)
ICEA (Needs Confirmation)
IDBD (Needs Confirmation)
IGED (Needs Confirmation)
IHAA (Needs Confirmation)
Codes Needing Confirmation: 33

ArnoudX 13:32, 23 July 2009 (UTC)

I'll confirm the AFIG since that's what I got Farming cape (t)  Lil cloud 9 Talk 18:39, 23 July 2009 (UTC)
Mine was BFEB. Ancient statuette WWTDD? Ancient statuette 18:39, 23 July 2009 (UTC)
Thanks Guys. Seems like a lot of B's so far. I'm thinking there are about 30 possibilities... If this is correct, a player with a Thieving Level far below the Thieving Requirement might be able to do it in 15 runs! ArnoudX 20:02, 23 July 2009 (UTC)
My code was "AAIH" User:Crystalis178 20:34, 23 July 2009 (EST)
GAFG is mine. I can see why Jagex would do this, it prevents it from spelling certain words. Unicorn horn dust Evil Yanks talk 02:05, 24 July 2009 (UTC)
I got "BDDB" Quipeace 9:35, 24 July 2009 (GMT+1)
My code was CABE. -- Quest point cape Lil Diriz 77 Talk Summoning-icon 08:57, 24 July 2009 (UTC)
BBAG was mine, I believe. --67.195.4.112 09:07, 24 July 2009 (UTC)

Mine was E-A-D-C! Vespire 21:45, 24 July 2009 (UTC)

All right, I'll add it to the list for ArnoudX Farming cape (t)  Lil cloud 9 Talk 21:54, 24 July 2009 (UTC)

I seem to remember having BGFI as my code. --ItsMrPants 07:54, 25 July 2009 (UTC)

Mine was BEID, I believe -- --MacGyverJr 08:34, 25 July 2009 (UTC)

I had HEBF. I first thought it was HEBE, but that was impossible... Miasmic blitz Hapi007 Talk! Sign! . 12:10, 25 July 2009 (UTC)

My code was GABA. dictature 13:02, 25 July 2009 (UTC)

My code was CCCI BigBob2007 13:40, 25 July 2009 (UTC)

Mine was FEAF. I wrote it down and also thought everyones was the same as FEAF sounds like THIEF which is in essence what I was. --82.2.53.42 16:26, 25 July 2009 (UTC)

My code was CFBG —The preceding unsigned comment was added by 96.50.63.70 (talk).

Mine was HEEB —The preceding unsigned comment was added by 12.177.63.62 (talk).

I had FHBH as a code.Mr. Zurkon 13:37, 26 July 2009 (UTC)

Mine was GEFC -- Gold ore Mercifull UK serv (Talk) 14:56, 26 July 2009 (UTC)

codegaba.th.png Hopefully this picture is enough of a confirmation. dictature 15:20, 26 July 2009 (UTC), edited 15:22, 26 July 2009 (UTC)

Mine was IGED —The preceding unsigned comment was added by 92.28.147.100 (talk).

I updated the count again. Unicorn horn dust Evil Yanks talk 03:33, 27 July 2009 (UTC)

My code was IDBD; still have it from my quest notes, yes I take notes. Rand14 04:56, 27 July 2009 (UTC)

Another new one - I had GCCB Cloud Shaper 09:34, 29 July 2009 (UTC)

I got a non-listed code CGIH - Hope ur research goes well

I am not 100% certain, as I did the quest several days ago, but I believe my code was BEGG-- Armadyl helmet Long Live Armadyl Armadyl helmet 22:31, 29 July 2009 (UTC)

Mine is new, FGHG

Mine was Baie

Mine was CBEH but i dont have a picture of it Happyman 01:45, 2 August 2009 (UTC)

Mine was FIIG, no proof, sorry ):

Another one: IHAA Miw 18:51, 3 August 2009 (UTC)

Twas DHHH. Also, the arrow keys on the door lock bit might be confusing, confused me and someone who I asked to help. tobylaneTalk 21:19, 3 August 2009 (UTC)

Another new one, but sorry no screenshot: AIEC

I just did quest and I got BFGC. I only read quest guides after completing, otherwise I would've got screenshot. -maczoso

Mine was FGHG, and I forgot to take a screenshot cause I was tryin to complete as fast as possible to get my questcape back. Quest point cape detail Bruxacosmica Talk-Highs Blue cape 21:43, 10 August 2009 (UTC)

Lil Cloud has updated up to this point. Unicorn horn dust Evil Yanks talk


DCGA 00:13, 15 August 2009 (UTC)

I haven't seen mine here yet, so I'll contribute - I had BAED. E.T. Prod U(Talk) 15:12, September 1, 2009 (UTC)

Mine was DADF, sorry I don't have a screenshot. Prayer-icon Sir Lenehan Smite old 10:02, September 2, 2009 (UTC)

~CLOSED~ I'm going to close this research as there is no conclusive evidence that only a set of codes are used. Farming cape (t)  Lil cloud 9 Talk 12:04, September 15, 2009 (UTC)

code Edit

my code was heah, pretty simple =)-- ebrr5 20:19, September 12, 2009 (UTC)

Glitch NOT fixed Edit

Yesterday, December 23rd, i got 66 thieving, and a message came up saying that i had all the levels, even though i was only 61 mining. The page says:

"When you got either 61 Agility, 64 Strength, 41 Summoning, or 64 Mining, the message came that "you have all the skill levels required for Curse of Arrav" even if you didn't have all skill requirements. This is fixed."

Well it isn't. I deleted that message, and will upload the picture, as soon as i figure out how to :pSwordfishguy 16:37, December 23, 2009 (UTC)

Ok, so I figure out how to upload the picture, but someone cropped it, ruining the purpose of it >.< The picture showed that the player had NOT gotten all the required levels, but the message still appeared. So whoever did this, can you explain why?



Ok I checked back again, been awhile, and someone re-uploaded the stats page :):):):):) thanks whoever did that. But... well... err... you highlighted smithing not mining :p

Thanks to whoever is doing this, I would but I'm rather inept with wiki editing technology. Swordfishguy 02:11, January 15, 2010 (UTC)

Music Edit

I just finished the quest and realized no music tracks were listed. I know two of them (The Heist, and Lamistard's Labyrinth), but I'm sure there is 1 more. If anyone doing the quest can verify/disprove this, it would be helpful.

Theiving boosts Edit

Can you use the abyssal lurkers special to meet the theiving requirement? It mentions the magpies spec but not the lurkers so I'm just curious to know if the lurkers spec works. -- Defence cape (t) Rabbit Fear Armadyl godsword 21:49, March 13, 2010 (UTC)

nvm it does work and picture proof -- Defence cape (t) Rabbit Fear Armadyl godsword 21:50, March 13, 2010 (UTC) thieve.png Arrav.png




I just started the quest with 64 thieving, and friend told me that you don't need the level to start the quest, you only need it when the time comes to use it. sorry I can't post pictures 24.155.82.176 00:06, July 9, 2010 (UTC)Edgemaster99

Sir VeylantzEdit

When you have brought the full canopic jar to Ali the Wise, he says we need to do something about the surveillance, and my player said "Sir Veylantz? Is he one of the Temple Knights?" Recruitment Drive is not listed on the quests required, so I'm wondering if players that have not completed this quest see this line, seeing as the Temple knights are supposed to be a secret intelligence agency.

65.129.160.74 01:42, June 18, 2012 (UTC)

Around Wikia's network

Random Wiki