FANDOM


Most of the images on the wiki have transparency applied to them. This involves deleting the image's background to make the subject clearer. Transparency may be applied before an image is uploaded or once it is already on the wiki. Previously uploaded images that editors need to add transparency to them can be found in Category:Images needing transparency, or Category:Images needing translucency if the image needs translucency applied.

This guide will cover how to apply transparency and translucency using GIMP. If you are not familiar with GIMP, you can check out our guide on getting GIMP and performing general functions with it here.

TransparencyEdit

  • Open your image in GIMP.
  • Under the Layer menu select Transparency and click the Add Alpha Channel option. Without an alpha channel you will not be able to add transparency.
  • Click the Free Select Tool. Make sure that anti-aliasing is turned on under the tool options.
  • Make an outline around the part of the image you want to keep by marking points around the image with the Free Select Tool (image).
    • It may help to zoom in to see the edges of the image more easily (Ctrl + mouse scroll wheel).
  • When you reach the end of the whole outline, click on your starting point to complete your selection. The individual points will disappear and the part of the image you wish to keep will be selected.
  • Press Ctrl + I to invert your selection so that background is selected.
  • Press delete so that the background is removed. The background should be replaced with a chequered background - this indicates that this part of the image is transparent.
  • If there are any background areas contained within the image you want to keep these can be removed by selecting them with the Free Select Tool and pressing delete without inverting your selection.
  • Go to Image and choose Autocrop to remove the extra background around your image.
  • Export your image to save it in the .png file format.
  • The image is now ready to upload!

Inventory icon images transparencyEdit

Inventory icon images can have transparency added more easily.

Use Select by Color Tool/Fuzzy Select Tool, and set the threshold to ~15. Be sure the "antialiasing" option is unticked.

Insert image here

Click on the background of the icon you wish to add transparency. For the New Interface System, this would usually be blue, while on Legacy Mode, it will be brown. Hold control+shift and repeat until the background behind the sprite has been (mostly) selected. Now press delete.

Insert image here

To remove an item sprite's shadow, set the threshold to 0, then click on the shadow. Alternatively, using Legacy Mode causes the shadow to become brown, making it easier to see.

Interface transparencyEdit

Interfaces are typically of the same size and have standard borders. Therefore it may be easier to delete parts of the interface border and copy and paste in some areas with transparency applied. There is a template for that here:

Transparency - interface templates

TranslucencyEdit

Easy methodEdit

This can be used for any images where particles or translucency are over a solid coloured background.

  • Apply regular transparency, excluding any areas with particles or translucency.
  • Select an area with particles using the Free Select Tool.
  • Select: Layer > Transparency > Color to Alpha.
  • Click on the bar of the Color to Alpha window and use the Color Picker to select the background colour from the original image (the colour of the background behind the particles that you want to get rid of).
  • Click okay on the Color Picker window and okay again on the Color to Alpha window. The background should be removed without affecting the colour of the particles/translucency: if it isn't then you may need to try one of the harder methods.
  • Go to Image > Autocrop to remove the extra background around your image.
  • Export your image to save it in the .png file format
  • The image is now ready to upload!

Translucency - hard methodEdit

Use this method if you want to add solid coloured translucency to an image that has not been taken on a solid background. This doesn't work for translucent areas which have patterns.

  • Add regular transparency if not already done, excluding the translucent areas.
  • Use the Free Select Tool to outline the part of the image that is translucent as above.
  • Change the colour of the selected area to white. Go to Colors > Brightness-Contrast, and move both sliders to the max.
  • Recolour the white area to an appropriate colour. You can do this using Colors > Color Balance; Colors > Hue-Saturation; or Colors > Colorize. Change the levels until you have a colour that matches what the area's colour should be.
  • Make the coloured area translucent by using the Eraser Tool on it. Change the tool's Opacity setting to determine how translucent area is. Around 22% opacity is typical: though you can change it depending on the subject of the image.
  • When you have added translucency to all the parts of the image that require it you should clean up the edges of the translucent areas, as they will not have anti-aliasing and will not be blended with the adjacent parts of the image.
    • When bordering an empty part of the image use the Free Select Tool to select a small portion of the edge of the section and delete it.
    • Use the Blur Tool to clean up areas inside the image: size less than 10 depending on size of image; convolve rate less than 10; and opacity at 100. Run the tool over the edges of the translucent areas.
  • Go to Image > Autocrop to remove the extra background around your image.
  • Export your image to save it in the .png file format
  • The image is now ready to upload!

Particles - hard methodEdit

Use for image where there are particles on a non-solid colour background.

  • Open the Layers window.
  • Apply transparency, excluding the areas with particles. Make sure you keep a copy of the original image to judge what the particles looked like.
  • Use the Free Select Tool to select the areas with particles. Cut and paste the selection. It will appear as Floating Selection (Pasted Layer) right-click this and select To New Layer.
  • Create a new layer that is transparent by right-clicking in the layers window and choosing New Layer and then selecting Transparency as the Layer Fill Type.
  • Use the Color Picker Tool to select the colour of the particles from the layer with the cut original particles.
  • Select a circular Paintbrush Tool, 2. Hardness 075 is ideal. Adjust opacity, typically around 20 is fine but this may be changed depending on the intensity of the original particles, and the paintbrush size, depending on how large the particles are.
  • Select the blank transparent layer and use the paintbrush to draw in the particles.
    • Start by making the general shape of the particle area. You can then add more particles in the parts which are more intense.
    • The particles should look like those in the original image, so be sure to compare to the original image and cut particle layer while creating the new particles. You should also compare to your plain background colour to check that the particles are not too light/dark.
  • Repeat for all the areas with particles.
  • When you are done, delete the layer containing the original particles and the layer with plain black/white fill by right-clicking them and selecting Delete Layer.
  • Go to Image and select Merge Visible Layers to combine the remaining layers.
  • Go to Image > Autocrop to remove the extra background around your image.
  • Export your image in to save it in the .png file format
  • The image is now ready to upload!

See alsoEdit

Want some more help?

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.